........attendi qualche secondo.

#adessonews solo agevolazioni personali e aziendali.

per le ricerche su Google, inserisci prima delle parole di ricerca:

#adessonews

Siamo operativi in tutta Italia

 

CERCA.X (funzione CERCA.X) – Supporto tecnico Microsoft #adessonewsitalia

Sintassi

La funzione CERCA.X esegue la ricerca in un intervallo o in una matrice e restituisce quindi l’elemento corrispondente alla prima corrispondenza che trova. Se non esiste alcuna corrispondenza, CERCA.X può restituire la corrispondenza più vicina (approssimativa). 

=CERCA.X(valore;matrice_ricerca;matrice_restituita;[se_non_trovato];[modalità_confronto];[modalità_ricerca]) 

Argomento

Descrizione

valore

Obbligatoria*

Valore da cercare per

*Se omesso, CERCA.X restituisce le celle vuote trovate in matrice_ricerca.   

matrice_ricerca

Obbligatorio

La matrice o l’intervallo in cui effettuare la ricerca

matrice_restituita

Obbligatorio

La matrice o l’intervallo da restituire

[se_non_trovato]

Facoltativo

Se non è stata trovata una corrispondenza valida, restituire il testo [se_non_trovato] che si specifica.

Se non viene trovata una corrispondenza valida e [se_non_trovato] manca, verrà restituito #N/A.

[modalità_confronto]

Facoltativo

Specificare il tipo di corrispondenza:

0 – Corrispondenza esatta. Se non trovata, restituisce #N/D. Questa è l’impostazione predefinita.

-1 – Corrispondenza esatta. Se non trovata, restituisce l’elemento successivo più piccolo.

1 – Corrispondenza esatta. Se non trovata, restituisce l’elemento successivo più grande.

2 – Una corrispondenza jolly in cui *, ? e ~ hanno un significato speciale.

[modalità_ricerca]

Facoltativo

Specificare la modalità di ricerca da usare:

1 – Effettuare una ricerca a partire dal primo elemento. Questa è l’impostazione predefinita.

-1 – Effettuare una ricerca inversa a partire dall’ultimo elemento.

2 – Effettuare una ricerca binaria basata sulla matrice di ricerca classificata in ordine crescente. Se non è classificata, vengono restituiti risultati non validi.

– 2 – Effettuare una ricerca binaria basata sulla matrice di ricerca classificata in ordine decrescente. Se non è classificata, vengono restituiti risultati non validi.

Esempi

L’esempio 1    utilizza XLOOKUP per cercare un nome di paese in un intervallo e quindi restituire il relativo prefisso telefonico del paese. Include gli argomenti valore (cella F2), matrice_ricerca (intervallo B2:B11), e matrice_restituita (intervallo D2:D11). Non include l’argomento modalità_confronto, perché CERCA.X produce una corrispondenza esatta per impostazione predefinita.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente. La formula è =CERCA.X(B2,B5:B14,C5:C14).

Nota: CERCA.X utilizza una matrice di ricerca e una matrice restituita, mentre VLOOKUP utilizza una singola matrice di tabelle seguita da un numero di indice di colonna. In questo caso la formula VLOOKUP equivalente sarà: =VLOOKUP(F2,B2:D11,3,FALSE)

———————————————————————————

L’esempio 2    cerca le informazioni sui dipendenti in base al numero ID di un dipendente. A differenza di VLOOKUP, CERCA.X può restituire una matrice con più elementi, quindi una singola formula può restituire sia il nome del dipendente sia il reparto dalle celle C5:D14.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente. La formula è =CERCA.X(B2,B5:B14,C5:D14,0,1)

———————————————————————————

L’esempio 3    aggiunge un argomento se_non_trovato all’esempio precedente.

Esempio della funzione CERCA.X usata per restituire il nome e il reparto di un dipendente in base all'ID dipendente con l’argomento se_non_trovato. La formula è =CERCA.X(B2,B5:B14,C5:D14,0,1, “dipendente non trovato”)

———————————————————————————

Nell’esempio 4     viene cercato nella colonna C il reddito personale immesso nella cella E2 per trovare un’aliquota di imposta corrispondente nella colonna B. L’argomento se_non_trovato viene impostato in modo da restituire 0 (zero) se non viene trovato alcun valore. L’argomento modalità_confronto è impostato su 1, quindi la funzione cercherà una corrispondenza esatta e, se non riesce a trovarne una, restituirà l’elemento seguente più grande. Infine, l’argomento modalità_ricercaè impostato su 1, quindi la funzione eseguirà la ricerca dal primo all’ultimo elemento.

Immagine della funzione CERCA.X usata per restituire un'aliquota di imposta in base al reddito massimo. Si tratta di una corrispondenza approssimativa. La formula è: =CERCA.X(E2,C2:C7,B2:B7,1,1)

Nota: La colonna matrice_ricerca di XARRAY si trova a destra della colonna matrice_restituita, mentre VLOOKUP può essere visualizzata solo da sinistra a destra.

———————————————————————————

Esempio 5    Usa una funzione CERCA.X annidata per eseguire una corrispondenza verticale e orizzontale allo stesso tempo. Cerca innanzitutto il Profitto lordo nella colonna B, quindi Qtr1 nella prima riga della tabella (intervallo C5:F5) e restituisce infine il valore all’intersezione di esse. Si tratta di un modo analogo all’uso combinato delle funzioni INDICE e CONFRONTA.

Suggerimento: È anche possibile usare CERCA.X al posto della funzione CERCA.ORIZZ.

Immagine della funzione CERCA.X usata per restituire dati orizzontali da una tabella annidando due CERCA.X. La formula è: =CERCA.X(D2,$B6:$B17,CERCA.X($C3,$C5:$G5,$C6:$G17))

Nota: La formula nelle celle D3:F3 è: =CERCA.X(D2,$B6:$B17,CERCA.X($C3,$C5:$G5,$C6:$G17)).

———————————————————————————

Esempio 6    usa la funzione SOMMAe due funzioni CERCA.X annidate per sommare tutti i valori tra due intervalli. In questo caso, si vogliono sommare i valori di uva e banane e includere quelli delle pere, che si trovano tra di essi.

Utilizzo di CERCA.X con SOMMA per sommare un intervallo di valori compresi tra due selezioni

La formula nella cella E3 è: =SOMMA(CERCA.X(B3;B6:B10;E6:E10):CERCA.X(C3;B6:B10;E6:E10))

Come funziona? CERCA.X restituisce un intervallo, quindi, quando esegue il calcolo, la formula finisce per avere l’aspetto seguente: =SOMMA($E$7:$E$9). È possibile vedere il funzionamento del processo selezionando una cella con una formula CERCA.X simile a questa, quindi selezionare Formule > Verifica formule > Valuta formula, e selezionareValuta per eseguire il calcolo.

Nota: Grazie all’MVP di Microsoft Excel, Bill Jelen, per aver suggerito questo esempio.

———————————————————————————

Clicca qui per collegarti al sito e articolo dell’autore

“https://support.microsoft.com/it-it/office/cerca-x-funzione-cerca-x-b7fd680e-6d10-43e6-84f9-88eae8bf5929”

Pubblichiamo solo i migliori articoli della rete. Clicca qui per visitare il sito di provenienza. SITE: the best of the best ⭐⭐⭐⭐⭐

Clicca qui per collegarti al sito e articolo dell’autore

La rete Adessonews è un aggregatore di news e replica gli articoli senza fini di lucro ma con finalità di critica, discussione od insegnamento, come previsto dall’art. 70 legge sul diritto d’autore e art. 41 della costituzione Italiana. Al termine di ciascun articolo è indicata la provenienza dell’articolo. Per richiedere la rimozione dell’articolo clicca qui

#adessonews

#adessonews

#adessonews

 

Richiedi info
1
Richiedi informazioni
Ciao Posso aiutarti?
Per qualsiasi informazione:
Inserisci il tuo nominativo e una descrizione sintetica dell'agevolazione o finanziamento richiesto.
Riceverai in tempi celeri una risposta.